`
844604778
  • 浏览: 550470 次
文章分类
社区版块
存档分类
最新评论

UVa 10474 Where is the Marble? (二分查找&equal_range()的使用)

 
阅读更多

10474 - Where is the Marble?

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=108&page=show_problem&problem=1415

Raju and Meena love to play with Marbles. They have got a lot of marbles with numbers written on them. At the beginning, Raju would place the marbles one after another in ascending order of the numbers written on them. Then Meena would ask Raju to find the first marble with a certain number. She would count 1...2...3. Raju gets one point for correct answer, and Meena gets the point if Raju fails. After some fixed number of trials the game ends and the player with maximum points wins. Today it's your chance to play as Raju. Being the smart kid, you'd be taking the favor of a computer. But don't underestimate Meena, she had written a program to keep track how much time you're taking to give all the answers. So now you have to write a program, which will help you in your role as Raju.

Input

There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins with 2 integers:Nthe number of marbles andQthe number of queries Mina would make. The nextNlines would contain the numbers written on theNmarbles. These marble numbers will not come in any particular order. FollowingQlines will haveQqueries. Be assured, none of the input numbers are greater than 10000 and none of them are negative.

Input is terminated by a test case whereN= 0andQ= 0.

Output

For each test case output the serial number of the case.

For each of the queries, print one line of output. The format of this line will depend upon whether or not the query number is written upon any of the marbles. The two different formats are described below:

  • `xfound aty', if the first marble with numberxwas found at positiony. Positions are numbered1, 2,...,N.
  • `xnot found', if the marble with numberxis not present.

Look at the output for sample input for details.

Sample Input

4 1
2
3
5
1
5
5 2
1
3
3
3
1
2
3
0 0

Sample Output

CASE# 1:
5 found at 4
CASE# 2:
2 not found
3 found at 3

使用equal_range()可破。


完整代码:

/*0.118s*/

#include<cstdio>
#include<algorithm>
using namespace std;

int num[10005];
pair<int*, int*> bounds;

int main()
{
	int n, q, cas = 0, i, qu;
	while (scanf("%d%d", &n, &q), n || q)
	{
		for (i = 0; i < n; ++i)
			scanf("%d", &num[i]);
		sort(num, num + n);
		printf("CASE# %d:\n", ++cas);
		while (q--)
		{
			scanf("%d", &qu);
			bounds = equal_range(num, num + n, qu);
			if (bounds.first == bounds.second) printf("%d not found\n", qu);
			else printf("%d found at %d\n", qu, bounds.first - num + 1);
		}
	}
	return 0;
}

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics