`
844604778
  • 浏览: 550575 次
文章分类
社区版块
存档分类
最新评论

UVa 369 Combinations (用double算组合数)

 
阅读更多

369 - Combinations

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=305

Computing the exact number of ways thatNthings can be takenMat a time can be a great challenge whenNand/orMbecome very large. Challenges are the stuff of contests. Therefore, you are to make just such a computation given the following:

GIVEN:

displaymath41

Compute theEXACTvalue of:

displaymath43

You may assume that the final value ofCwill fit in a 32-bit Pascal LongInt or a C long.

For the record, the exact value of 100! is:

     93,326,215,443,944,152,681,699,238,856,266,700,490,715,968,264,381,621,
        468,592,963,895,217,599,993,229,915,608,941,463,976,156,518,286,253,
        697,920,827,223,758,251,185,210,916,864,000,000,000,000,000,000,000,000

Input and Output

The input to this program will be one or more lines each containing zero or more leading spaces, a value forN, one or more spaces, and a value forM. The last line of the input file will contain a dummyN,Mpair with both values equal to zero. Your program should terminate when this line is read.

The output from this program should be in the form:

Nthings takenMat a time isCexactly.

Sample Input

     100  6
      20  5
      18  6
       0  0

Sample Output

100 things taken 6 at a time is 1192052400 exactly.
20 things taken 5 at a time is 15504 exactly.
18 things taken 6 at a time is 18564 exactly.

注意这句话:

You may assume that the final value ofCwill fit in a 32-bit Pascal LongInt or a C long.


完整代码:

/*0.022s*/

#include<cstdio>

int main()
{
	int N, M, i;
	double C;
	while (scanf("%d%d", &N, &M), N)
	{
		C = 1.0;
		for (i = N; i > N - M; --i) C *= (double)i;
		for (i = 2; i <= M; ++i) C /= (double)i;
		printf("%d things taken %d at a time is %.0f exactly.\n", N, M, C);
	}
	return 0;
}

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics