`
844604778
  • 浏览: 551562 次
文章分类
社区版块
存档分类
最新评论

UVa 10049 Self-describing Sequence (自描述序列&二分递推)

阅读更多

10049 - Self-describing Sequence

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=34&page=show_problem&problem=990

Solomon Golomb'sself­describing sequence$\langle f(1), f(2), f(3), \dots \rangle$is the only non­decreasing sequence of positive integers with the property that it contains exactlyf(k) occurrences ofkfor eachk. A few moments thought reveals that the sequence must begin as follows:


\begin{displaymath}\begin{array}{c\vert cccccccccccc}\mbox{\boldmath $n$} & 1 &......)$} & 1 & 2 & 2 & 3 & 3 & 4 & 4 & 4 & 5 & 5 & 5 & 6\end{array}\end{displaymath}

In this problem you are expected to write a program that calculates the value off(n) given the value ofn.

Input

The input may contain multiple test cases. Each test case occupies a separate line and contains an integern($1 \le n \le 2,000,000,000$). The input terminates with a test case containing a value0fornand this case must not be processed.

Output

For each test case in the input output the value off(n) on a separate line.

Sample Input

100
9999
123456
1000000000
0

Sample Output

21
356
1684
438744

1. 如何构造一个增长速率较快的递推式?

注意到f(n)增长缓慢,不妨利用其反函数g(n)=max{m | f(m)=n}(比如g(4)=8),然后再求一次反函数f(n)=min{k | g[k]>=n}即可得到f(n)。

随后由f(n)的定义有g(n)=g(n-1)+f(n)=g(n-1)+min{k | g[k]>=n}

(比如g(4)=g(3)+f(4)=5+3=8,g(5)=g(4)+f(5)=8+3=11)


2. 如何计算min{k | g[k]>=n}

用二分查找。


完整代码:

/*0.075s*/

#include<cstdio>
#include<algorithm>
const int M = 700000;
using namespace std;

long long g[M];

int main()
{
	g[1] = 1;
	g[2] = 3;
	for (int i = 3; i < M; ++i)
		g[i] = g[i - 1] + (lower_bound(g + 1, g + i, i) - g);
	int n;
	while (scanf("%d", &n), n)
		printf("%d\n", lower_bound(g + 1, g + M, n) - g);
	return 0;
}

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics